What are the browser requirements for the Elevate Platform?

The browsers requirements depend on the product.

Hacker's Mind

  • Internet Explorer (IE) 10-11
  • Microsoft Edge
  • Firefox
  • Google Chrome

Elevate Platform (EP)

  • Google Chrome
  • Firefox
Was this article helpful?
0 out of 0 found this helpful